Homepageupdate: WoltLab Suite 5.3.3 und 5.3.4

Zitat

Wir haben soeben Updates für unsere Produkte freigegeben:

  • WoltLab Suite 5.3.3

WoltLab Suite Calendar

  • Das Foto wurde nicht mehr dargestellt, wenn das Formular Fehler enthielt. 5.2
  • Es war auf Grund eines irrtümlichen Änderung in einem vorherigen Update nicht mehr möglich, Felder in Themenformularen zu deaktivieren. 5.2 5.3
  • Die Berechnung der Anzahl von Einträgen in einer Kategorie war fehlerhaft. 3.1 5.2

WoltLab Suite Core: Importer

  • phpBB 3.1+


    • Unterstützung for Argon2-basiererte Prüfsummen von Passwörtern. 5.3

WoltLab Suite Core

  • Paketlisten von Paketservern von Drittanbietern konnten teilweise die Berechnung von verfügbaren Updates beeinträchtigen. 3.1 5.2
  • Die Anzeige der Vorschaugrafik wird bei eingebetetten Dateinanhängen nun erzwungen, wenn der Betrachter die Vollversion nicht sehen darf. 3.1 5.2
  • Die Fehlerbehandlung für fehlgeschlagene Cronjobs wurde verbessert um temporäre Probleme zu kompensieren. 3.1 5.2
  • Individuelle Berechtigungen für hochgeladene Medien wurden nicht korrekt gespeichert. 3.1 5.2 5.3
  • Die Erkennung von Dateiendungen funktionierte bei einer Großschreibung nicht korrekt. 5.2 5.3
  • Die PHP-API für Datenbankänderungen per PIP wurde verbessert. 5.2
  • Einige Probleme im Zusammenhang mit der FormBuilder-API wurden behoben. 5.2
  • Die Beschreibung von Trophäen wurde in der Liste der letzten Aktivitäten nicht korrekt dargestellt. 5.2 5.3
  • Der Besitzerstatus des aktuellen Benutzers wird nun zur Laufzeit berechnet, statt auf vorberechnete Werte zurückzugreifen. 5.2 5.3
  • Vorschaugrafiken von Stilen waren nach einem Update nicht mehr korrekt hinterlegt, dieses Updates stellt diese wenn nötig wieder her. 5.3
  • Die Geschwindigkeit der "Benutzer Online"-Box wurde verbessert. 5.3
  • Der Wert "all" für "environment" bei Event-Listenern war nicht nutzbar. 5.3


Hinterher kam noch ein Sicherheitsupdate 5.3.4

Zitat

WoltLab Suite Core

  • (SICHERHEIT) Eine Prüfung wurde ergänzt um sicherzustellen, dass alle für eine Zusammenfügung ausgewählten Benutze bearbeitet werden dürfen. 5.3 5.2 3.1 3.0
  • Ein Problem bei der Entfernung von Datenbank-Indizes über die PHP Datenbank-API wurde behoben. 5.3 5.2
  • Die Guzzle-HTTP-Bibliothek hat den HTTP-Proxy-Server fehlerhaft verarbeitet. 5.3WoltLab Suite Core
  • (SICHERHEIT) Eine Prüfung wurde ergänzt um sicherzustellen, dass alle für eine Zusammenfügung ausgewählten Benutze bearbeitet werden dürfen. 5.3 5.2 3.1 3.0
  • Ein Problem bei der Entfernung von Datenbank-Indizes über die PHP Datenbank-API wurde behoben. 5.3 5.2
  • Die Guzzle-HTTP-Bibliothek hat den HTTP-Proxy-Server fehlerhaft verarbeitet. 5.3